Wednesday, April 30, 2008

Visual Studio 2005 install problem

We have had this twice at work in the last few weeks... It's kinda of bizarre that Visual Studio will fail from the DVD install, wrongly asking for DVD1 when it already has it.. Microsoft's premier development tool can't install on XP... perverse!

When Sam rang me today asking me how i solved the problem, i honestly couldn't remember. looking thru my google history didn't show the answer either!

But then i remembered, simply copy both dvds to the same directory on your harddisk and the installer will find the missing files, must be a screwy install definition.

On the subject of Microsoft, long live Yahoo because i think diversity is good. But get XP3 out the door, i am sure there are now zero day bugs exposed to the general population because of the delay. Plenty of other companies was broken with SP2, why are you so special? Risky ..

Monday, April 28, 2008

Blogger captcha's are getting impossible

Anyone noticed that blogger's captcha images are starting to get ridiculously hard to read?

Wednesday, April 23, 2008

Apache on win32 with stopped a Coldfusion service is a bit broken

I am not sure why, but apache won't serve files on win32 if Coldfusion is installed and not running. Try to access plain old html like the CFDOCS will just spin in the browser, not good. Starting the Coldfusion service will solve the problem.

I have seen a similar issue with Mapguide and Apache, sometimes you can't restart Mapguide 2.0 until you cycle the Mapguide Apache service.

Thursday, April 17, 2008

configure: error: C preprocessor "/lib/cpp" fails sanity check - SOLUTION

I hit the following whilst try to compile apache on RHEL4 as part of Mapguide 2.0

checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
configure failed for srclib/apr
Apache build failed (0).

in plain english, maybe your kernel sources was missing (or skipped),
run up2date --configure to check for skipped packages, look for the item pkgSkipList

update -u "@KDE Software Development"
was the tip to pretty much get everything you need

but it stil didn't work, so i installed apt, which then recommended apt-get --fix-broken install which cleaned up some stuff.

I then hit an error about not finding a shared gcc info file... then i simply re-installed gcc and bang it worked

Custom Mapguide Search Search

I just created a Mapguide Resources Search with google custom search, feel free volunteer and add sites

Mystery http corruption with Firefox

It's probably one of the extensions i have installed, but my Firefox often returns the wrong url or calls the wrong host for some requests.

I can see this in my local apache logs, i see the occasional aspx request (even tho there is no aspx stuff on my server) showing up and sometimes I see http requests coming back as plain text with the http headers and raw html.

It's not an easy bug to search for, but i thought I would blog in case anyone else is seeing the same issue...

as it's usually extensions which break firefox, here's what i'm running

Adblock Plus
Download Statusbar
English (Australian) Dictionary
Fission (Disabled in Browser)
IE Tab
Java Console 6.0.00
Live HTTP Headers
View formatted source (format source extension)
Web Developer
YSlow (Disabled in Browser)


PS: I had to debug some javascript stuff in IE yesterday and my god was it painful! It's just so bloody 1990's when you compare it to the debugging experience in Firefox.

I hope IE8 learns how to return which script the error actually occurs in, rather than the base page, when using a complex library like Openlayers.

Thursday, April 10, 2008

Initial Mapguide 2.0 testing on Linux Results

I repeated my Mapguide Tile Service load testing with JMeter and found that the (debug at least) build on Linux was stable and didn't crash. So the "Crash with MgInvalidStreamHeaderException with GETTILEIMAGE (load test)" issue might be win32 specific, or maybe just not present in the debug build.

I uploaded a new load test in trac which has "Http Request Defaults" setup so you can choose which server and port you want to test.

Next up i will try some more FDO providers other than SDF

Strange javascript bug, functions loosing lines?

I have a complex form with FCKEditor and some Jquery, today i was debugging an issue where a function run after a form action would just magically stop halfway through. I eventually did alert(functionName) which in firefox dumps the function code.

To my suprise the dumped function missed the last line which called the next function in the chain. View source confirmed that the code was as i wrote it. So I edited the function, moving the text around (figuring whitespace might be that affecting it!) and refreshed and this time it worked, the dumped function had the last function call.

Problem solved. On to the next one

Mapguide Openlayers Sheboygan tiled map example

Here is a demo of using a Mapguide tiled map with OpenLayers, the OpenLayers Mapguide example doesn't have an example for a map you can access yourself like the Sheboygan sample.

The secret source to getting it working is

var extent = new OpenLayers.Bounds(-87.865114442365922,43.665065564837931, -87.595394059497067,43.823852564430069);
var tempScales =[1000,1930.6977300000001,3727.5937199999998, 7196.8567300000004, 13894.95494,26826.95795,51794.746789999997,100000];

Documentation for for OpenLayers.Layer.MapGuide & Mapguide Example

Following my testing, I believe the tiled map's under mapguide have a bug which relates to the tile grid not being correct

Wednesday, April 09, 2008

Build notes for Mapguide 2.0 on CentOS

My notes when following these build guides: BuildingAndConfiguringMGOSOnLinux.pdf and OpenSourceBuild__README.html

My Linux knowledge is rather average, i know bits and have used it for over 10 years on and off, occasionally some Solaris, but i am by no means an expert.

  1. It's not supported yet on 64-bit Linux, use a 32-bit version
  2. Make sure you install the GNOME Software Development packages, otherwise you will hit an error with xslt-config being missing (libxslt-devel libxslt) but this was a big hassle on RHEL 4.
  3. If your using Vmware Player and your on a dual core machine, add numvcpus = "2" to your .VMX file to use both CPU's otherwise you'll only ever see 50% CPU usage
  4. I started with RHEL 4 and then switched to using CentOS coz i didn't have a Redhat Network account which gave me access and yum wasn't playing nice for some reason (couldn't find packages?) where as CentOS just works with any login requirement.
  5. I used the thoughtpolice vmware image @
  6. For Centos the Yum Extender is pretty good for managing packages, use "yum install yumextender"
  7. I built the FDO, i believe the prebuilt RHEL4 fdo binaries get installed to /usr/local/fdo-3.3.0/lib , the download notes don't make that clear (i guess it would be better as an rpm really?).
  8. If you have the apr packages installed that will break apache if they are the 0.94 versions, the error message i got was "undefined reference to 'apr_os_uuid_get'". I just removed the package, which did uninstall the default apache httpd and other stuff like subversion also depends on (so it's the wrong thing to do!).
  9. SSH is your friend :) I use Putty and Winscp on XP
  10. I changed the fdo and from #!/bin/sh to #!/bin/bash after i hit "acinclude.m4:7: warning: underquoted definition of FDO_HELP_STRING"
  11. Nabble FDO Users and Mapguide are the best source of information and the best place to ask questions for this stuff. Just search before you ask!
  12. uncomment the lines: AddHandler mgmapagent_handler fcgi and LoadModule mgmapagent_module modules/ in /usr/local/mapguideopensource/webserverextensions/apache/conf/mapguide.conf or you will get the mapguide.fcgi binary returned :(
  13. I had a font problem, almost wingdingy which was solved by copying verdana.ttf from /usr/share/fonts/msttcorefonts
So it's up and running, mapadmin works and i managed to load a sample package. the map didn't show tho at first, until i did #12 ...


BTW My Wmare image ended up being about 6.8 Gb at the end

Sunday, April 06, 2008


The charting component in Coldfusion is really quite flexible and useful.

Beyond the basic embedded styles, you can use the built in editor for the
CFCHART underlying engine, WebCharts3D.


Using this you can modify the style for any graph, and there's a lot
of possibilities.

The first thing i changed was turning off the animation for the flash graphs
by changing <morph morph="grow"/> to <morph morph="none">

The other default option (it's a change from the CF 7 behaviour in CFMX) is to disable the auto-interpolation. Basically, when it's enabled, any missing data will be filled in with estimated values, which is very frustrating when you don't know about it!

Thankfully I found this livedocs comment which grabbed my attention more than the change notes in the doco.

by changing this at the top of the XML style file
<frameChart autoAdjust="false" is3D="false" isInterpolated="true">
<frameChart autoAdjust="false" is3D="false" isInterpolated="false">

Given how easy Coldfusion is to use, i would suggest it's worth trying out if you are going to do some database driven web based charting.

I was suggest that you don't ever modify the file in the default styles directory, always make a copy in your application tree, that way it will minimise deployment hassles and we all hate them don't we?

Friday, April 04, 2008

Newstopia is brilliant!

Newstopia was great this week, check it out before next wednesday, coz this weeks espisode was a pearler :)

that's also for anyone not in Australia or who can't receive SBS

trust me, it witty, funny topical stuff